Page d'accueilFindIt !Contact Cahier Java

Cahier Java

 Forum Java

Ce forum est dédié à l'ouvrage Bien programmer en Java 7, ainsi qu'aux éditions précédentes des Cahiers du Programmeur Java.
Utilisez-le pour toute demande d'information supplémentaire ou pour toute suggestion au sujet de ces ouvrages.
Pour les informations relatives au Cahier du programmeur Swing, merci d'utiliser le forum qui lui est dédié.
Vous pouvez consulter ces forums librement. Pour y participer, inscrivez-vous tout d'abord.

Sujets Messages récents Identification Inscription
Messages du sujet Problème de version eclipse 3.1

bougameza

Ville : rabat
Membre depuis : 7 mars 2007
Messages : 1
 7 mars 2007 à 13:51
Bonjour,
j'utilise eclipse 3.1 et quand je compile mes fichiers .java il m'affiche le message suivant:
bad class file:C:\Programfiles\Java\jre1.5.0_10\lib\rt.jar(java/util/ArrayList.class)
[javac] class file has wrong version 49.0, should be 48.0
[javac] Please remove or make sure it appears in the correct subdirectory of the classpath.
[javac] import java.util.ArrayList;

est que vous pouviez m'aider pour régler ce pb?
Merci

Manu

Ville : Paris / France
Membre depuis : 29 avr. 2003
Messages : 394
 10 mars 2007 à 19:44
Etes-vous sûr que c'est à la compilation ?
Ce doit être plutôt à l'exécution de votre programme, et c'est parce que vous tentez d'exécuter avec Java 1.4 des classes compilées avec Java 5. Vérifier dans les options de votre projet (menu Project>Properties, propriété "Java Compiler") que vous avez bien choisi le compilateur 1.4 dans l'option "Compiler compliance level"
---
Manu (moderator/modérateur)


Page d'accueilFindIt !ContactDébut de la page

© Copyrights 1997-2014 eTeks - Tous droits réservés

Cahier Java