Home pageFind It!Contact PJAPJA documentation


 PJA Toolkit forum

This forum is dedicated to PJA Toolkit.
You may read freely the messages it contents. If you want to write a message or answer to a subject, subscribe to it first.

Subjects Recent messages Login Subscribe

Messages of subject Could not find class : com.eteks.ava2d.PJAGraphicsEnvironment


Location : India
Member since : Jun 7, 2004
Messages : 1
 Jun 7, 2004 at 8:42 PM
I'm trying to generate a PDF page using PJA tool kit in a jsp which runs in iPlanet web server 4.1 on a HP Unix m/c. I've set the following :-
1) Included DISPLAY variable and 'exported' it in the 'start' script of the server instance. DISPLAY=<ipaddress of my m/c>:0.0
2) Also included the paths of 'pja.jar' and 'rtgraphics.jar' as the NSES_JDK_RUNTIME_CLASSPATH in the same 'start' script.
3) Included all the jar files in the jvm classpath of the server in 'jvm12.conf' file.
4) Included the System.setProperty function in my code for setting PJAToolKit, font environment and graphics environment.

The strange thing is that the above setup worked on a Sun Solaris m/c but it is not working on a HP Unix m/c. Server is iPlanet web server 4.1 on both of them. I'm getting the error 'Could not find class : com.eteks.java2d.PJAGraphicsEnvironment' on HP Unix m/c. Would you pls. tell me the reason why it is behaving differently on two different m/cs.


Location : Singapore
Member since : Jul 19, 2004
Messages : 1
 Jul 19, 2004 at 8:50 AM
I am trying to genrate PDF file in iPlanet 6.0 SP4 with Java 1.3.1_04 running in Solaris using Apache FOP, i am getting the same error (java.lang.Error: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment). When i tried to generate PDF using a stand-alone java program, by setting properties in command line (as mentioned in FAQ), i am able to generate PDF file.
But when i changed the same program by setting properties in program, as
System.setProperty("sun.boot.class.path",System.getProperty("sun.boot.class.path") + ":"+"/tmp/pja/pja.jar");

and executed without command line arguments i am getting "java.lang.Error: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment"

Pls advice me what i have missed out. Thanx in advance
R Prabakar

Home pageFind It!ContactTop

© Copyrights 1997-2023 eTeks - All rights reserved

PJAPJA documentation