Home pageFind It!Contact PJAPJA documentation


 PJA Toolkit forum

This forum is dedicated to PJA Toolkit.
You may read freely the messages it contents. If you want to write a message or answer to a subject, subscribe to it first.

Subjects Recent messages Login Subscribe

Messages of subject Could not find class: com.eteks.java2d.PJAGraphicsEnvironment


Location : St. George, UT USA
Member since : Jul 29, 2004
Messages : 2
 Jul 29, 2004 at 1:24 AM
I am running a web application with these settings:

Caucho Resin version 3.0.7
JDK 1.4
SUSE Linux

I start the resin application with these commands:


I still get this following error:

java.lang.Error: Could not find class: com.eteks.java2d.PJAGraphicsEnvironment
at java.awt.GraphicsEnvironment.getLocalGraphicsEnvironment(GraphicsEnvironment.java:68)
at java.awt.Font.initializeFont(Font.java:303)
at java.awt.Font.<init>(Font.java:339)
at PiechartServlet.doGet(PiechartServlet.java:231)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:126)
at javax.servlet.http.HttpServlet.service(HttpServlet.java:103)
at com.caucho.server.dispatch.ServletFilterChain.doFilter(ServletFilterChain.java:113)
at com.caucho.server.cache.CacheFilterChain.doFilter(CacheFilterChain.java:211)
at com.caucho.server.webapp.WebAppFilterChain.doFilter(WebAppFilterChain.java:177)
at com.caucho.server.dispatch.ServletInvocation.service(ServletInvocation.java:221)
at com.caucho.server.http.HttpRequest.handleRequest(HttpRequest.java:263)
at com.caucho.server.port.TcpConnection.run(TcpConnection.java:323)
at com.caucho.util.ThreadPool.runTasks(ThreadPool.java:430)
at com.caucho.util.ThreadPool.run(ThreadPool.java:377)
at java.lang.Thread.run(Thread.java:536)

I have also tried without using the java.awt.headless property, but then I get a headless exception. Anyhelp would be greatly apperciated.



Location : Paris / France
Member since : Apr 29, 2003
Messages : 394
 Jul 30, 2004 at 10:04 AM
I hope the page http://www.caucho.com/support/resin-interest/0107/0574.html will help you...
Manu (moderator/modérateur)


Location : Warrenville / US
Member since : Aug 16, 2005
Messages : 1
 Aug 16, 2005 at 4:38 PM
I see other people have had this issue, but it looks like no one placed a solustion.
I am running WebSphere V5.0 and I have set up the bootclass and added the JVM
custom properties awt.toolkit com.eteks.awt.PJAToolkit
java.awt.fonts /local/java/IBM/J1.3/lib/fonts
java.awt.graphicsenv com.eteks.java2d.PJAGraphicsEnvironment
These properly show up in the servant.jvm.properties file but the application is not able to resolve finding the pja.jar file.
Any ideas?


Member since : Oct 12, 2007
Messages : 1
 Oct 12, 2007 at 5:34 AM
I know there is similiar topics about this, but I already try to add some options but still cannot work.

I try to run PJA in windows XP Home Edition,
actually I want it to run in unix machine without X11 library,

this is my options that I add from command line:
-Xbootclasspath/a:C:\Program/Files\Java\jdk1.6.0_02\jre\lib\ext\pja.jar:C:\Program/Files\Java\jdk1.6.0_02\jre\lib\ext\rtgraphics.jar -Djava.awt.graphicsenv=com.eteks.java2d.PJAGraphicsEnvironment -Dawt.toolkit=com.eteks.awt.PJAToolkit -Djava2d.font.usePlatformFont=false -Djava.awt.fonts=C:\Program/Files\Java\jdk1.6.0_02\jre\lib\fonts -Duser.home=C:\Program/Files\Java\jdk1.6.0_02\jre\lib\ext
-classpath C:\Program/Files\Java\jdk1.6.0_02\jre\lib\ext\pjatools.jar

when I use -verbose i see this
[Loaded com.eteks.java2d.PJABufferedImage from file:/C:/Program%20Files/Java/jdk1.6.0_02/jre/lib/ext/pja.jar]

altough pja.jar already loaded but, my program still cannot run
any help for this ?

o yes I just learn to programming with Java and I use JDK 1.6


Home pageFind It!ContactTop

© Copyrights 1997-2023 eTeks - All rights reserved

PJAPJA documentation